<!doctype html>
<html lang="en-US" class="">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no">
		<link rel="profile" href="https://gmpg.org/xfn/11">
	<title>Terrell Owens Catches Touchdown in Fan Controlled Football Debut &#8211; LX</title>
<link rel="preload" as="script" href="https://www.lx.com/wp-content/themes/nbc-station-lx/client/build/js/common.9d1e7ff183d85b040aae.bundle.min.js?ver=1.0.2">
<link rel="preload" as="script" href="https://www.lx.com/wp-content/themes/nbc-station-lx/client/build/js/lx.6252cfa3740cdb73f90f.bundle.min.js?ver=1.0.2">
<link rel="preload" as="image" href="https://ots.nbcwpshield.com/wp-content/uploads/2022/04/Web-220416-terrell-owens.jpg?quality=85&#038;strip=all&#038;resize=320%2C180" imagesrcset="https://ots.nbcwpshield.com/wp-content/uploads/2022/04/Web-220416-terrell-owens.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=375&amp;h=211&amp;crop=1 375w, https://ots.nbcwpshield.com/wp-content/uploads/2022/04/Web-220416-terrell-owens.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=575&amp;h=323&amp;crop=1 575w, https://ots.nbcwpshield.com/wp-content/uploads/2022/04/Web-220416-terrell-owens.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=775&amp;h=436&amp;crop=1 775w, https://ots.nbcwpshield.com/wp-content/uploads/2022/04/Web-220416-terrell-owens.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=975&amp;h=548&amp;crop=1 975w, https://ots.nbcwpshield.com/wp-content/uploads/2022/04/Web-220416-terrell-owens.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=1175&amp;h=661&amp;crop=1 1175w, https://ots.nbcwpshield.com/wp-content/uploads/2022/04/Web-220416-terrell-owens.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=1375&amp;h=773&amp;crop=1 1375w, https://ots.nbcwpshield.com/wp-content/uploads/2022/04/Web-220416-terrell-owens.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=1575&amp;h=886&amp;crop=1 1575w, https://ots.nbcwpshield.com/wp-content/uploads/2022/04/Web-220416-terrell-owens.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=1775&amp;h=998&amp;crop=1 1775w">
<link rel='dns-prefetch' href='//z.moatads.com' />
<link rel='dns-prefetch' href='//assets.adobedtm.com' />
<link rel='dns-prefetch' href='//s.w.org' />
	<link rel="preconnect" href="https://fonts.googleapis.com">
	<link rel="preconnect" href="https://fonts.gstatic.com" crossorigin>
	<link
		href="https://fonts.googleapis.com/css2?family=Montserrat:wght@400;500;700&family=Playfair+Display:ital,wght@0,400;0,500;1,400;1,500&display=swap"
		rel="stylesheet"
				media="print"
		onload="this.media='all'"
			>
	<style class="wp-asset-manager lx" type="text/css">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</style><style class="wp-asset-manager lx-article" type="text/css">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</style><script id='ad-layers-dfp-js-extra'>
var adLayersDFP = {"layerDebugLabel":"Current ad layer","consoleDebugLabel":"Switch to Google console","adUnitPrefix":"div-gpt-ad-"};
</script>
<script src='https://www.lx.com/wp-content/plugins/ad-layers-nbc/js/ad-layers-dfp.js?ver=0.0.9' id='ad-layers-dfp-js'></script>
<script id='ad-layers-js-extra'>
var adLayersAdServer = {"jsAPIClass":"AdLayersDFPAPI"};
</script>
<script src='https://www.lx.com/wp-content/plugins/ad-layers-nbc/js/ad-layers.js?ver=0.0.9' id='ad-layers-js'></script>
<script async src='https://assets.adobedtm.com/a2ef59fba8e9/3ba8c6b033ff/launch-6a742ce4ddf5.min.js?ver=1.0.2' id='adobe-launch-js'></script>
<link rel="https://api.w.org/" href="https://www.lx.com/wp-json/" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.lx.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.lx.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.9" />
<link rel="canonical" href="https://www.lx.com/fan-controlled-football/terrell-owens-catches-touchdown-in-fan-controlled-football-debut/51546/" />
<link rel="alternate" type="application/json+oembed" href="https://www.lx.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.lx.com%2Ffan-controlled-football%2Fterrell-owens-catches-touchdown-in-fan-controlled-football-debut%2F51546%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.lx.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.lx.com%2Ffan-controlled-football%2Fterrell-owens-catches-touchdown-in-fan-controlled-football-debut%2F51546%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style><script>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</script><meta property="og:site_name" content="LX" /><meta name="google-site-verification" content="imqiJsyiSCQbViT7Q45fiT6PzB5gNzmsgrikC1CseWI" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@nbclx" /><meta name="twitter:creator" content="@nbclx" /><meta property="og:type" content="article" /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta name="description" content="Terrell Owens made his way back onto the field…and into the end zone. The Hall of Fame wide receiver returned to professional football on Saturday, debuting..." /><meta property="og:description" content="Terrell Owens made his way back onto the field…and into the end zone. The Hall of Fame wide receiver returned to professional football on Saturday, debuting in the Fan Controlled Football league. The first reception for the 48-year-old came on the final play of the game, as he caught a 12-yard touchdown during his Zappers’ 20-12 loss to the Shoulda…" /><meta name="twitter:description" content="Terrell Owens made his way back onto the field…and into the end zone. The Hall of Fame wide receiver returned to professional football on Saturday, debuting in the Fan Controlled Football league. The first reception for the 48-year-old came on the final play of the game, as he caught a 12-yard touchdown during his Zappers’ 20-12 loss to the Shoulda…" /><meta property="og:title" content="Terrell Owens Catches Touchdown in Fan Controlled Football Debut" /><meta name="twitter:title" content="Terrell Owens Catches Touchdown in Fan Controlled Football Debut" /><meta name="keywords" content="fan controlled football, football, johnny manziel, LX, nbclx, Terrell Owens" /><meta property="og:url" content="https://www.lx.com/fan-controlled-football/terrell-owens-catches-touchdown-in-fan-controlled-football-debut/51546/" /><meta name="twitter:url" content="https://www.lx.com/fan-controlled-football/terrell-owens-catches-touchdown-in-fan-controlled-football-debut/51546/" /><meta name="sailthru.title" content="Terrell Owens Catches Touchdown in Fan Controlled Football Debut" /><meta name="sailthru.description" content="Terrell Owens made his way back onto the field…and into the end zone. The Hall of Fame wide receiver returned to professional football on Saturday, debuting..." /><meta name="sailthru.tags" content="fan controlled football, football, johnny manziel, LX, nbclx, Terrell Owens" /><meta name="sailthru.tags" content="fan controlled football, football, johnny manziel, LX, nbclx, Terrell Owens" /><meta name="sailthru.type" content="article" /><meta name="sailthru.date" content="2022-04-16T21:58:06+00:00" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="675" /><meta property="og:image" content="https://ots.nbcwpshield.com/wp-content/uploads/2022/04/Web-220416-terrell-owens.jpg?quality=85&#038;strip=all&#038;resize=1200%2C675" /><meta name="twitter:image" content="https://ots.nbcwpshield.com/wp-content/uploads/2022/04/Web-220416-terrell-owens.jpg?quality=85&#038;strip=all&#038;resize=1200%2C675" /><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":"https:\/\/www.lx.com\/fan-controlled-football\/terrell-owens-catches-touchdown-in-fan-controlled-football-debut\/51546\/","headline":"Terrell Owens Catches Touchdown in Fan Controlled Football Debut","datePublished":"2022-04-16T21:58:06","dateModified":"2022-04-16T21:58:09","description":"Terrell Owens made his way back onto the field\u2026and into the end zone. The Hall of Fame wide receiver returned to professional football on Saturday, debuting\u2026","speakable":{"@type":"SpeakableSpecification","cssSelector":[".article-headline",".article-subtitle"]},"keywords":"fan controlled football, football, johnny manziel, LX, nbclx, Terrell Owens","publisher":{"@type":"Organization","name":"LX","logo":{"@type":"ImageObject","height":60,"url":"https:\/\/lx.com\/wp-content\/uploads\/2019\/09\/light_amp_lx.png","width":160}},"image":{"@type":"ImageObject","height":675,"url":"https:\/\/ots.nbcwpshield.com\/wp-content\/uploads\/2022\/04\/Web-220416-terrell-owens.jpg?quality=85&strip=all&resize=1200%2C675","width":1200},"author":{"@type":"Person","name":"Mike Gavin"}}</script>							<script type='text/javascript'>
				var dfpAdUnits = {};
				var googletag = googletag || {};
				googletag.cmd = googletag.cmd || [];
				(function() {
				var gads = document.createElement('script');
				gads.async = true;
				gads.type = 'text/javascript';
				var useSSL = 'https:' == document.location.protocol;
				gads.src = (useSSL ? 'https:' : 'http:') +
				'//www.googletagservices.com/tag/js/gpt.js';
				var node = document.getElementsByTagName('script')[0];
				node.parentNode.insertBefore(gads, node);
				})();
				</script>
												<script type="text/javascript">
			var dfpBuiltMappings = {}, dfpAdUnits = {};

			if (768 <= window.innerWidth) {									googletag.cmd.push(function() {
					dfpBuiltMappings["bottombox"] = googletag.sizeMapping().addSize([768,1],[[300,250],[300,600]]).build();
dfpBuiltMappings["topbanner"] = googletag.sizeMapping().addSize([768,1],[[970,90],[970,66],[970,250]]).build();
dfpBuiltMappings["topbox"] = googletag.sizeMapping().addSize([768,1],[[300,250],[300,600]]).build();
dfpBuiltMappings["logo"] = googletag.sizeMapping().addSize([768,1],[[88,31],[120,60]]).build();
					});
					var dfpAdDetails = {"topbanner":{"path":"\/2620\/ots_web\/lx\/culture","sizes":[[970,90],[970,66],[970,250]],"targeting":[]},"topbox":{"path":"\/2620\/ots_web\/lx\/culture","sizes":[[300,250],[300,600]],"targeting":[]},"bottombox":{"path":"\/2620\/ots_web\/lx\/culture","sizes":[[300,250],[300,600]],"targeting":[]},"logo":{"path":"\/2620\/ots_web\/lx\/culture","sizes":[[88,31],[120,60]],"targeting":[]}};
					var dfpSizeMapping = {"bottombox":[[[768,1],[[300,250],[300,600]]]],"topbanner":[[[768,1],[[970,90],[970,66],[970,250]]]],"topbox":[[[768,1],[[300,250],[300,600]]]],"logo":[[[768,1],[[88,31],[120,60]]]]};

					 } else { 									googletag.cmd.push(function() {
					dfpBuiltMappings["mobiletopbanner"] = googletag.sizeMapping().addSize([1,1],[[320,50]]).build();
dfpBuiltMappings["mobilemultibox"] = googletag.sizeMapping().addSize([1,1],[[300,250],[300,100],[320,50]]).build();
dfpBuiltMappings["logo"] = googletag.sizeMapping().addSize([1,1],[[88,31]]).build();
dfpBuiltMappings["mobilebackstage"] = googletag.sizeMapping().addSize([1,1],[[1,1]]).build();
dfpAdUnits["mobilebackstage"] = googletag.defineSlot("\/2620\/ots_mobile\/lx_mobileweb\/culture",[1,1],"div-gpt-ad-mobilebackstage").defineSizeMapping(dfpBuiltMappings["mobilebackstage"]).addService(googletag.pubads());
					});
					var dfpAdDetails = {"mobiletopbanner":{"path":"\/2620\/ots_mobile\/lx_mobileweb\/culture","sizes":[[320,50]],"targeting":[]},"mobilemultibox":{"path":"\/2620\/ots_mobile\/lx_mobileweb\/culture","sizes":[[300,250],[300,100],[320,50]],"targeting":[]},"logo":{"path":"\/2620\/ots_mobile\/lx_mobileweb\/culture","sizes":[[88,31]],"targeting":[]},"mobilebackstage":{"path":"\/2620\/ots_mobile\/lx_mobileweb\/culture","sizes":[[1,1]],"targeting":[]}};
					var dfpSizeMapping = {"mobiletopbanner":[[[1,1],[[320,50]]]],"mobilemultibox":[[[1,1],[[300,250],[300,100],[320,50]]]],"logo":[[[1,1],[[88,31]]]],"mobilebackstage":[[[1,1],[[1,1]]]]};

													}					googletag.cmd.push(function() {
					googletag.pubads().enableAsyncRendering();
googletag.pubads().collapseEmptyDivs();
					googletag.pubads().addEventListener('slotRenderEnded', function(event) {
						var slotElementId = event.slot.getSlotElementId();
						if (false === event.isEmpty) {
							if (0 <= slotElementId.indexOf('topbanner')) {
								document.body.classList.add("topbanner");
							}
							if (0 <= slotElementId.indexOf('logo')) {
								document.querySelector('#' + slotElementId).classList.add('logo-rendered');
							} else {
								document.querySelector('#' + slotElementId).classList.add('ad-rendered');
							}
						}
					});
						googletag.pubads().setTargeting("zipcode", localStorage.getItem("zipCode") || nbc.zipCode );

	var isMobile = window.matchMedia('screen and (max-width: 767px)').matches;
	googletag.pubads().setTargeting("gpt1", isMobile ? "ots_mobile" : "ots_web");
	googletag.pubads().setTargeting("platform", isMobile ? "mobile" : "desktop");
			googletag.pubads().setTargeting("source", "www.lx.com");
				googletag.pubads().setTargeting("pageid", "104151546");
				googletag.pubads().setTargeting("pageid2", "104151546");
				googletag.pubads().setTargeting("sect", "fan-controlled-football");
				googletag.pubads().setTargeting("sub", "");
				googletag.pubads().setTargeting("call", "LX");
				googletag.pubads().setTargeting("region", "lx");
				googletag.pubads().setTargeting("stationtype", "nbc");
				googletag.pubads().setTargeting("tags", "culture,fan-controlled-football,sports,fan-controlled-football,football,johnny-manziel,lx,nbclx,terrell-owens");
				googletag.pubads().setTargeting("gpt2", "LX");
				googletag.pubads().setTargeting("station", "ots");
				googletag.pubads().setTargeting("sponsor", "");
				googletag.pubads().setTargeting("excl_cat", "fan-controlled-football");
		
					googletag.enableServices();
				});
								var dfpAdLayer = {"post_id":6079,"title":"Home Ad Layer"};

			</script>
			<link rel="amphtml" href="https://www.lx.com/fan-controlled-football/terrell-owens-catches-touchdown-in-fan-controlled-football-debut/51546/?amp"><link rel="icon" href="https://ots.nbcwpshield.com/wp-content/uploads/2019/09/cropped-Favicon.png?fit=32%2C32&#038;quality=85&#038;strip=all" sizes="32x32" />
<link rel="icon" href="https://ots.nbcwpshield.com/wp-content/uploads/2019/09/cropped-Favicon.png?fit=192%2C192&#038;quality=85&#038;strip=all" sizes="192x192" />
<link rel="apple-touch-icon" href="https://ots.nbcwpshield.com/wp-content/uploads/2019/09/cropped-Favicon.png?fit=180%2C180&#038;quality=85&#038;strip=all" />
<meta name="msapplication-TileImage" content="https://ots.nbcwpshield.com/wp-content/uploads/2019/09/cropped-Favicon.png?fit=270%2C270&#038;quality=85&#038;strip=all" />
</head>
<body class="post-template-default single single-post postid-51546 single-format-standard station-nbc lx has-featured-image short-hero">
	<div id="header" class="header">
	<a href="https://www.lx.com/live/" class="header-mobile-watch-live-link">Watch Live</a>
	<div class="header-logo">
		<a href="https://www.lx.com" class="header-logo-link">
			<img src="https://www.lx.com/wp-content/themes/nbc-station-lx/img/a-branding-logo@3x.png" alt="LX" />
		</a>
	</div>
		<button id="header-nav-toggle" class="header-nav-toggle"></button>
	<nav class="header-nav">
		<div class="header-watch-live">
			<a href="https://www.lx.com/live/" class="header-watch-live-link ">
				<h4 class="header-watch-live-title">Watch Live</h4>
									<div id="watch-live" class="watch-live"></div>
							</a>
		</div>
		<ul id="menu-upper-flyout-menu" class="header-menu-primary"><li id="menu-item-51420" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-51420"><a href="/culture/">Culture</a>
<ul class="sub-menu">
	<li id="menu-item-51421" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51421"><a href="/culture/entertainment/">Entertainment</a></li>
	<li id="menu-item-51422" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51422"><a href="/culture/social-media/">Social Media</a></li>
	<li id="menu-item-51423" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-51423"><a href="/culture/sports/">Sports</a></li>
</ul>
</li>
<li id="menu-item-51424" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-51424"><a href="/health/">Health</a>
<ul class="sub-menu">
	<li id="menu-item-51425" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51425"><a href="/health/covid-19/">COVID-19</a></li>
	<li id="menu-item-51426" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51426"><a href="/health/mental-health/">Mental Health</a></li>
	<li id="menu-item-51427" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51427"><a href="/health/relationships/">Relationships</a></li>
</ul>
</li>
<li id="menu-item-51428" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-51428"><a href="/money/">Money</a>
<ul class="sub-menu">
	<li id="menu-item-51429" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51429"><a href="/money/cryptocurrency/">Cryptocurrency</a></li>
	<li id="menu-item-51430" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51430"><a href="/money/economy/">Economy</a></li>
	<li id="menu-item-51431" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51431"><a href="/money/personal-finance/">Personal Finance</a></li>
	<li id="menu-item-51432" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51432"><a href="/money/student-debt/">Student Debt</a></li>
</ul>
</li>
<li id="menu-item-6018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6018"><a href="/politics/">Politics</a>
<ul class="sub-menu">
	<li id="menu-item-51433" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51433"><a href="/politics/world-news/">World News</a></li>
</ul>
</li>
<li id="menu-item-6017" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6017"><a href="/climate/">Saving Our Earth</a></li>
<li id="menu-item-6019" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6019"><a href="/science-tech/">Science & Technology</a></li>
<li id="menu-item-44443" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44443"><a href="/community/">Your Community</a></li>
<li id="menu-item-33003" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33003"><a href="/lx-presents/">LX Presents</a></li>
<li id="menu-item-40467" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40467"><a href="https://www.lx.com/where-to-watch/">Where To Watch</a></li>
</ul>		<div class="header-nav-more">
			<button id="header-nav-more-toggle" class="header-nav-more-toggle">See More on LX</button>
			<ul id="header-menu-secondary" class="header-menu-secondary"><li id="menu-item-12734" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12734"><a href="https://www.lx.com/about-us/">About Us</a></li>
<li id="menu-item-6124" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6124"><a href="https://www.lx.com/where-to-watch/">Where To Watch</a></li>
<li id="menu-item-21363" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21363"><a href="https://www.lx.com/watch-schedule/">Programming Schedule</a></li>
<li id="menu-item-6021" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6021"><a href="https://www.lx.com/newsletters/">Sign Up</a></li>
<li id="menu-item-36875" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36875"><a href="https://www.lx.com/meet-the-team/">Meet the Team</a></li>
<li id="menu-item-12733" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12733"><a href="https://www.lx.com/frequently-asked-questions/">Frequently Asked Questions</a></li>
<li id="menu-item-13965" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13965"><a href="https://www.lx.com/contact-us/">Contact Us</a></li>
<li id="menu-item-50085" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50085"><a href="/your-voice-your-story/">Your Voice, Your Story</a></li>
<li id="menu-item-6020" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6020"><a href="https://www.lx.com/terms/">Terms of Service</a></li>
<li id="menu-item-6022" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6022"><a target="_blank" rel="noopener noreferrer" href="https://www.nbcuniversal.com/privacy?brandA=Owned_Stations&#038;intake=LX">Privacy Policy</a></li>
<li id="menu-item-12666" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12666"><a href="https://www.nbcuniversal.com/privacy/notrtoo?brandA=Owned_Stations&#038;intake=LX">Do Not Sell My Personal Information</a></li>
<li id="menu-item-16445" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16445"><a href="https://www.nbcuniversal.com/privacy/california-consumer-privacy-act?intake=LX">CA Notice</a></li>
<li id="menu-item-18365" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18365"><a target="_blank" rel="noopener noreferrer" href="https://www.nbcuniversal.com/privacy/cookies#accordionheader2">Ad Choices</a></li>
</ul>		</div>
		<h4 class="header-social-title">Follow us</h4>
		<div class="header-social-icons">
			<a href="https://www.instagram.com/nbclx/" target="_blank" class="instagram">Instagram</a>
			<a href="https://www.facebook.com/NBCLX/" target="_blank" class="facebook">Facebook</a>
			<a href="https://twitter.com/nbclx" target="_blank" class="twitter">Twitter</a>
			<a href="https://www.youtube.com/nbclx?sub_confirmation=1" target="_blank" class="youtube">Youtube</a>
		</div>
		<img src="/wp-content/themes/nbc-station-lx/img/footer_nbcuniversal-logo@3x.png" width="235" height="40" loading="lazy" alt="NBCUniversal" class="header-logo-nbcu" />
	</nav>
</div>

	<div class="site-header__trending">
		<span class="site-header__trending-label">Trending</span>
		<nav class="site-header__trending-nav">
								<a data-lid="Russia-Ukraine Crisis" data-lpos="trending-stories-module" href="https://www.lx.com/tag/russia-ukraine-crisis/" class="site-header__trending-nav-item">Russia-Ukraine Crisis</a>
					<a data-lid="Fan Controlled Football" data-lpos="trending-stories-module" href="https://www.lx.com/tag/fan-controlled-football" class="site-header__trending-nav-item">Fan Controlled Football</a>
					<a data-lid="Inflation" data-lpos="trending-stories-module" href="https://www.lx.com/tag/inflation/" class="site-header__trending-nav-item">Inflation</a>
		
			</nav>
		<div class="site-header__trending-toggle">
			<button class="trending-toggle"><span class="screen-reader-text">Expand</span></button>
		</div>
	</div>
	<main id="main" class="site-content">
		<div id="cards" class="cards">
			<article class="article post-51546 post type-post status-publish format-standard has-post-thumbnail hentry category-culture category-fan-controlled-football category-sports tag-fan-controlled-football tag-football tag-johnny-manziel tag-lx tag-nbclx tag-terrell-owens" itemScope itemType="https://schema.org/Article">
			<figure class="article-hero">
			<img src="https://ots.nbcwpshield.com/wp-content/uploads/2022/04/Web-220416-terrell-owens.jpg?quality=85&#038;strip=all&#038;resize=320%2C180" srcset="https://ots.nbcwpshield.com/wp-content/uploads/2022/04/Web-220416-terrell-owens.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=375&amp;h=211&amp;crop=1 375w, https://ots.nbcwpshield.com/wp-content/uploads/2022/04/Web-220416-terrell-owens.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=575&amp;h=323&amp;crop=1 575w, https://ots.nbcwpshield.com/wp-content/uploads/2022/04/Web-220416-terrell-owens.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=775&amp;h=436&amp;crop=1 775w, https://ots.nbcwpshield.com/wp-content/uploads/2022/04/Web-220416-terrell-owens.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=975&amp;h=548&amp;crop=1 975w, https://ots.nbcwpshield.com/wp-content/uploads/2022/04/Web-220416-terrell-owens.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=1175&amp;h=661&amp;crop=1 1175w, https://ots.nbcwpshield.com/wp-content/uploads/2022/04/Web-220416-terrell-owens.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=1375&amp;h=773&amp;crop=1 1375w, https://ots.nbcwpshield.com/wp-content/uploads/2022/04/Web-220416-terrell-owens.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=1575&amp;h=886&amp;crop=1 1575w, https://ots.nbcwpshield.com/wp-content/uploads/2022/04/Web-220416-terrell-owens.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=1775&amp;h=998&amp;crop=1 1775w" sizes="(max-width: 768px) 100vw, (max-width: 1280px) 700px, 1000px" alt="Terrell Owens" decoding="async"/>		</figure>
		<header class="article-header">
		<div class="article-eyebrow" itemProp="articleSection">
			<a href="https://www.lx.com/tag/terrell-owens/">Terrell Owens</a>		</div>
		<h1 class="article-title" itemProp="headline">
			Terrell Owens Catches Touchdown in Fan Controlled Football Debut		</h1>
					<div class="article-summary">
				The 48-year-old Hall of Famer returned to professional football on Saturday			</div>
				<div class="article-meta">
							<img src="https://ots.nbcwpshield.com/wp-content/uploads/2020/07/Screen-Shot-2020-07-28-at-3.35.07-PM.jpg?quality=85&#038;strip=all&#038;resize=150%2C150" alt="LX" class="article-author-avatar" loading="lazy" />				<div class="article-author" itemProp="author">
					Mike Gavin				</div>
										<time class="article-timestamp" itemProp="datePublished">
					4 seconds ago				</time>
										<button
			class="share-button article-share"
			data-title="Terrell Owens Catches Touchdown in Fan Controlled Football Debut"
			data-url="https://www.lx.com/fan-controlled-football/terrell-owens-catches-touchdown-in-fan-controlled-football-debut/51546/"
			data-video-network-id=""
			data-video-id=""
			data-id="1:41:51546"
			data-type="article"
			data-tag="fan-controlled-football|football|johnny-manziel|lx|nbclx|terrell-owens"
			data-section="fan-controlled-football"
		/>					</div>
	</header>
	<div class="article-content" itemProp="articleBody">
		
<p>Terrell Owens made his way back onto the field…and into the end zone.</p>

<p>The Hall of Fame wide receiver returned to professional football on Saturday, debuting in the Fan Controlled Football league. The first reception for the 48-year-old came on the final play of the game, as he caught a 12-yard touchdown during his Zappers' 20-12 loss to the Shoulda Been Stars.</p>
<!-- nbc-inline-ad -->
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">THE YEAR? 2022. THE TOUCHDOWN SCORER? TERRELL OWENS. <br><br>LFG. <a href="https://t.co/ZKAY2RMCzJ">pic.twitter.com/ZKAY2RMCzJ</a></p>&mdash; Fan Controlled Football (@fcflio) <a href="https://twitter.com/fcflio/status/1515492452328779778?ref_src=twsrc%5Etfw">April 17, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<p>Wearing "Prototype81" in place of his name on the back of his No. 81 jersey, Owens was the star attraction during opening day of the second season of Fan Controlled Football, a 7-on-7 indoor league that <a href="https://www.lx.com/culture/sports/fan-controlled-football-101-what-is-it-and-how-does-it-work/50781/" data-type="URL" data-id="https://www.lx.com/culture/sports/fan-controlled-football-101-what-is-it-and-how-does-it-work/50781/">empowers fans to call offensive plays</a>.</p>

<p>Fans and Zappers quarterback Danny Southwick looked for Owens early, targeting him five times on the opening drive.</p>
<div class="article-recirc">
	<h2 class="article-recirc-heading">More FCF News from NBCLX</h2>
	<p class="article-recirc-subheading"></p>
						<h3 class="article-recirc-title">
				<a href="https://www.lx.com/culture/sports/fan-controlled-football-101-what-is-it-and-how-does-it-work/50781/">
					Fan Controlled Football 101: What is it and How Does it Work?				</a>
			</h3>
								<h3 class="article-recirc-title">
				<a href="https://www.lx.com/culture/sports/10-fan-controlled-football-rules-to-know-for-the-2022-season/51189/">
					[LX-NATL] 10 Fan Controlled Football Rules to Know for the 2022 Season				</a>
			</h3>
			</div>

<p>Owens, who last played in the NFL in 2010, had his defender beat on a deep ball down the sideline early in the second half but the throw was short. Later in the drive, on 4th-and-15, Southwick avoided the sack and threw downfield to Owens, who leapt to get his hands on the ball but couldn't hold on for the catch.</p>

<p>With the Zappers trailing 14-6, Southwick targeted Owens on consecutive plays in the end zone, with the second attempt drawing a pass interference to put the ball at the two-yard line. Southwick's next pass was intercepted with just over five minutes remaining.</p>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">WIDE RECEIVER. NUMBER 81. TERRELL. OWENS. <a href="https://t.co/B5ixK9M17B">pic.twitter.com/B5ixK9M17B</a></p>&mdash; Fan Controlled Football (@fcflio) <a href="https://twitter.com/fcflio/status/1515468642179338242?ref_src=twsrc%5Etfw">April 16, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<p>Owens was expected to team with former Cleveland Browns quarterback Johnny Manziel, who returned for his second season in the league, but it was announced during Saturday's broadcast that the former Heisman Trophy felt he needed more preparation after arriving to camp late.</p>

<p>Owens spent eight seasons with the 49ers before being traded to the Philadelphia Eagles, helping to lead them to the Super Bowl in 2004. Owens spent three seasons with the Dallas Cowboys before finishing his career with the Buffalo Bills and Cincinnati Bengals.</p>

<iframe src="https://art19.com/shows/ddaf27fb-00ac-471e-9b97-af73cb4172d9/embed?playlist_type=playlist" width="100%" height="200" frameborder="0"></iframe>

<p>Owens was inducted into the Football Hall of Fame in 2018 after finishing with 15,934 receiving yards, which trails only Jerry Rice and Larry Fitzgerald for most all time. He has the eight most catches in league history with 1,078 receptions.</p>

<p>He now has his first catch — and touchdown — in Fan Controlled Football.</p>

<p>Famous for his boisterous touchdown celebrations, his first in FCF was toned down with the game having already been decided. So, if Owens — known for hyping his upcoming performances with the line "Get your popcorn ready" — was planning to celebrate by dumping popcorn over his helmet as he once did in the NFL, it will have to wait for his next touchdown.</p>

<p><strong><em><a href="https://www.lx.com/where-to-watch/">Watch Fan Controlled Football every Saturday on NBCLX</a> over the air, on cable, at <a href="https://www.lx.com/live/">LX.com</a> and on your favorite streaming platform.  </em></strong></p>
<div id="div-gpt-ad-bottombox_" class=" gpt-bottombox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'bottombox_', format: 'bottombox', targeting: {"slot":"bottombox","pos":"bottombox"} });
			</script>	</div>
</article>
		</div>
		<div id="modal" class="modal"></div>
	</main>
<script></script>	<!-- Facebook Pixel Code -->
	<img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=2776168482666848&ev=PageView&noscript=1"/>
	<!-- End Facebook Pixel Code -->
		<script type="text/javascript">
	(function() {
		var _sf_async_config      = window._sf_async_config = window._sf_async_config || {};
		_sf_async_config.domain   = "lx.com";
		_sf_async_config.uid      = 15527;
		_sf_async_config.sections = "";
		_sf_async_config.authors  = "Mike Gavin";
		_sf_async_config.title    = "Terrell Owens Catches Touchdown in Fan Controlled Football Debut";
				_sf_async_config.useCanonical = true;;
		_sf_async_config.useCanonicalDomain = true;
		
		var e = document.createElement('script');
		var n = document.getElementsByTagName('script')[0];
		e.type = 'text/javascript';
		e.async = true;
		e.src = '//static.chartbeat.com/js/chartbeat.js';
		n.parentNode.insertBefore(e, n);
	})();
	</script>
			<!-- Begin comScore Tag -->
		<script>
			(function() {
				var usPrivacyCookie = new RegExp("usprivacy=([^;]+)").exec(document.cookie),
					usPrivacy = null !== usPrivacyCookie ? unescape(usPrivacyCookie[1]) : undefined,
					csUCFR = '1YYN' === usPrivacy ? '0': '',
					s = document.createElement("script"),
					el = document.getElementsByTagName("script")[0];

				window._comscore = window._comscore || [];

				window._comscore.push({
					c1: "2",
					c2: "6035083",
					cs_ucfr: csUCFR,
				});

				s.async = true;
				s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
				el.parentNode.insertBefore(s, el);
			})();
		</script>
		<noscript>
			<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035083&cv=2.0&cj=1" />
		</noscript>
		<!-- End comScore Tag -->
		<link rel='stylesheet' id='lx-share-css'  href='https://www.lx.com/wp-content/themes/nbc-station-lx/client/build/css/share.039faea7707bfed81089.min.css?ver=1.0.2' media='all' />
<link rel='stylesheet' id='lx-newsletter-css'  href='https://www.lx.com/wp-content/themes/nbc-station-lx/client/build/css/newsletter.b3f4dd0ca25813560036.min.css?ver=1.0.2' media='all' />
<link rel='stylesheet' id='lx-card-css'  href='https://www.lx.com/wp-content/themes/nbc-station-lx/client/build/css/card.7dfc0b23d5e98f7bbfb3.min.css?ver=1.0.2' media='all' />
<script src='https://www.lx.com/wp-content/mu-plugins/jetpack-9.4/_inc/build/photon/photon.min.js?ver=20191001' id='jetpack-photon-js'></script>
<script src='https://www.lx.com/wp-content/themes/nbc-station-lx/client/build/js/common.9d1e7ff183d85b040aae.bundle.min.js?ver=1.0.2' id='lx-common-js'></script>
<script id='lx-js-extra'>
var lx = {"paginationUrl":"https:\/\/www.lx.com\/fan-controlled-football\/terrell-owens-catches-touchdown-in-fan-controlled-football-debut\/51546\/"};
</script>
<script async src='https://www.lx.com/wp-content/themes/nbc-station-lx/client/build/js/lx.6252cfa3740cdb73f90f.bundle.min.js?ver=1.0.2' id='lx-js'></script>
<script async src='https://www.lx.com/wp-content/themes/nbc-station-lx/client/build/js/newsletter.7398f53272b789db0a42.bundle.min.js?ver=1.0.2' id='lx-newsletter-js'></script>
<script src='https://z.moatads.com/nbcuyieldheader7581548001/moatheader.js?ver=1.0.0' id='moat-js'></script>
<script src='https://stats.wp.com/e-202215.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.4.1',blog:'165474740',post:'51546',tz:'-4',srv:'www.lx.com',hp:'vip'} ]);
	_stq.push([ 'clickTrackerInit', '165474740', '51546' ]);
</script>
</body>
</html>
